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Report Maker - Graphs 

Graph fields pull data entered into the chart.  Graph fields are formatted to illustrate 2 
dimensional and 3 dimensional line, bar and pie graphs. Under report Options the report type 
must be set to Graph for printing graphs. The Graph tab defines the field. 

Bar Graphs 
This is the most common graph type and is a good choice for comparing multiple data 
elements across time. 
 

 
Example 
The facility has implemented new menus and dining procedures, and would like to track the 
number of occurrences of meal intake < 75% over time compared to 75% or more over time. 

1. Access the Report Maker and create a Graph report template: 

• Click American Data > ECS and follow the path Setup > Report > Report Maker.  

• Select the Options icon . Select the Multiple Clients per Report checkbox and 

the Report Type of Graph. Also consider making the report Landscape orientation 

if you are graphing many elements or many time increments. 

2. Add the first element you want to graph (Meals <75%): 

• Click on the Add Field icon . 

• Select graph and click OK. 

• Select Bar (the default) and click OK. 

• In the Elements area, click Add. Enter the element name (“<75%”) and click OK. 

• In Element Properties, select the Show Labels checkbox.  
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• In the Words area, click Add > CNA/Breakfast > and select the words for 50%, 25%, 

and 0%, then click OK. 

• In Based on, keep the Entry Date option selected. 

• In Include, select the Current Entries checkbox. 

• In Other, select the Word checkbox. 

3. Add the second element:  

• In the Elements area, click Add. Enter the element name (“75-100%”) and click OK. 

• In Element Properties, select the Show Labels checkbox. 

• In the Words area, click Add > CNA/Breakfast > and select the words for 100% and 

75%, then click OK. Repeat for Lunch and Dinner. 

• In Based on, keep the Entry Date option selected. 

• In Include, select the Current Entries checkbox. 

• In Other, select the Word checkbox.  

4. Select the Element Settings: 

• How much time will the graph cover (e.g., 3 months, 6 months, 12 months)? For this 

example, we will set the graph to look back 3 months. (Start 3 +/- Months Ago). 

• What time increments do we want to see within the graph? We will select 1 week 

increments (Series 1 +/- Week Increments). 

• Set the Values Calculation. We want to Count Words/Values (count up all of the 

meals), not Count Clients (how many clients ate more, or less than 75%). 

5. Select the Properties tab: 

• Enter a Title (Meal Intakes). 

• Make the Legend visible and position as desired (Bottom). 

• Add 3D effects as desired. 

6. Select the Look tab: 

• Select the Primary Field checkbox (to allow date selection). 

7. Click Close. 

8. Position the field and stretch to meet margins. The graph will auto-size to fit the size of 

the field (the larger the field, the larger the graph). 

9. Click the Save icon to save and name your report (Graph– Meal Intake). Select Sites and 

User Groups as appropriate. 
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Line Graphs 
Line graphs are an excellent choice for monitoring one data element over time, especially for 
individual clients. Line elements are unique in that they can each display each occurrence of 
an event during a time period.  

 
Example 
A resident’s INR levels fluctuate. The facility would like to display the results on a graph.  

1. Access the Report Maker. Since the report is for one client per page, select a similar 

report and make a copy of it, so that you do not need to create the resident identifier 

fields from scratch.  

• Click American Data - ECS and follow the path Setup > Report > Report Maker.  

• Click the Open icon . Filter for Graph reports. Select “Skin – PUSH Scores Area 
1” and click OK. 

• Make a copy of the report by clicking Save As and name your report (Graph – 
INR Results). Select Sites and user Groups as appropriate.  

• The Report Options icon will already have the desired settings (NOT “Multiple 
Clients per Report,” and Report Type “Graph.” The report is also “Landscape” 
orientation, which is fine.) 

2. Delete unwanted fields: in this case, select Wound Location, and click Delete, as well as 
the green “Report Label.” Also delete the Pressure Ulcer Healing Graph field because 
we will be making our own. 
 

3. Create the Graph  field: 

• Click the Add Field icon . 

• Select Graph and click OK. 

• Select Line and click OK. 
• In the Elements area, click Add. Enter the element name (“INR”) and click OK. 

• In Element Properties, select the Show Labels checkbox.  
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• In the Words area, click Add > Nurse Charting/Lab Results > select the word INR 

Result, then click OK. 

• In Based on, keep the Entry Date option selected.  

• In Include, select the Current Entries checkbox. 

• In Show Values, select All Values, and then click on the Values button and select 

“Text” value. Click OK. 

• Leave the Other area blank. 

4. Select the Element Settings: 

• How much time will the graph cover (e.g., 3 months, 6 months, 12 months)? For this 

example we will set the graph to look back 3 months. (Start 3 +/- Months Ago). 

• What time increments do we want to see within the graph? We will select 1 week 

increments (Series 1 +/- Week Increments). 

• Set the Values Calculation. (We want to “Count Words/Values” not Count Clients.)  

5. Select the Properties tab: 

• Enter a Title (INR Results). 

• Since there’s only one item being graphed, you can probably leave the legend set 

to “Not Visible.” 

• Add 3D effects as desired. 

6. Select the Look tab: 

• Select the Primary Field checkbox (to allow date selection). 

• You may also select the Master Field checkbox, so that if you run the report on a 

group of residents, it will exclude those without INR results automatically. 

7. Click Close. 

8. Position the field below the client identifiers and stretch to meet margins. The graph 

will auto-size to fit the size of the field (the larger the field, the larger the graph). 

9. Click the Save icon to save changes. 
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Pie Graphs 
Pie graphs are designed to show the breakdown of data within one data element. 
 

 
Example 
A facility has an initiative to attempt more non-pharmacological interventions for breakthrough 
or acute pain episodes before PRN analgesics are used. They want to analyze how often 
different interventions are attempted.  

1. Access the Report Maker and create a Graph report template: 

• Click American Data - ECS > Setup > Report > Report Maker.  

• Select the Report Options icon. Select the Multiple Clients per Report checkbox 

and a Report Type of Graph. You may also consider making the report Landscape 

orientation if you wish. 

2. Add the graph field: 

• Click on the Add Field icon  . 

• Select Graph and click OK. 

• Select Pie and click OK. Add the first element (Exercise): 

• In the Elements area, click Add. Enter the element name (“Exercise”) and click OK. 

• In the Words area, click Add > Nurse Charting/PRN Meds > and select the words 

for Exercise, then click OK. 

• In Based on, keep the Entry Date option selected.  

• In Include, select the Current Entries checkbox. 

• In Other, select the Word checkbox. 

3. Add additional elements (Rest, Distraction, Activity, Position Changes, ROM, 

Stretching, Massage, PRN Analgesic):  

• In the Elements area, click Add. Enter the next element name and click OK. 
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• In the Words area, click Add > Nurse Charting/PRN Meds > and select the needed 

word, then click OK.  

• In Based on, keep the Entry Date option selected.  

• In Include, select the Current Entries checkbox. 

• In Other, select the Word checkbox. 

• Repeat steps for each element. 

4. Select the Element Settings: 

• How much time will the graph cover (e.g., 3 months, 6 months, 12 months)? For this 

example we will set the graph to look back 1 month. 

• Set the Values Calculation. (We want to “Count Words/Values,” not Count Clients.) 

5. Select the Properties tab: 

• Enter a Title (Pain Interventions). 

• Make the Legend visible and position as desired (Bottom). 

• Add 3D effects as desired. 

• Set the Pie Properties: For Show Labels, select Show Percent, or Show Value (for 

this example we will Show Percent). 

6. Select the Look tab: 

• Select the Primary Field checkbox (to allow date selection). 

7. Click Close. 

8. Position the field and stretch to meet margins. The graph will auto-size to fit the size of 

the field (the larger the field, the larger the graph). 

9. Click the Save icon to save and name your report  (Graph – Meal Intake). Select Sites 

and user Groups as appropriate. 

Gauge Graphs 
Gauge graphs help the facility to see if they are meeting a goal or target. 
 

 
 

Example 
The facility has implemented new marketing strategies to improve admission rates. The facility 
would like between 20-30 residents each month and would like to display the monthly 
admission rate at a monthly meeting.  
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1. Access the Report Maker and create a Graph report template: 

• Click American Data - ECS and follow the path Setup > Report > Report Maker.  

• Select the Report Options icon. Select the Multiple Clients per Report checkbox 

and the Graph report type. You may also consider making the report “Landscape” 

orientation if you wish. 

2. Add the graph field. 

• Click the Add Field icon . 

• Select Graph and click OK. 

• Select Gauge and click OK. 

3. Add the Elements. Gauge graphs are unique –the elements are the thresholds for the 

goal you are trying to achieve. Examples of elements for Gauge graphs might be 

“Poor, Fail, Good, Excellent,” or “Below Target, At Target, Above Target.” Each element 

represents a % of the total, and the total for all elements together must equal 100%. 

• This gauge graph will be a half circle, or have a 180 degree radius. We will allow 

from 0 – 50 admissions to be displayed. This means that 0-20 admissions represent 

40% of the total, 20-30 represent 20% of the total, and 30-50 represent the last 40% 

of the total. 

• In the Elements area, click Add. Enter the element name (“Below Target”) and click 

OK. 

• Enter what % of the total graph this element represents (40%). 

• Click Add to add another element called “At Target.” This will be 20% of the total.  

• Enter the last element, “Above Target.” This will be 40% of the total. 

4. Define where in the record the data will pull from. 

• In the Gauge Value area, select Add, > Face Sheet / Status > and select the needed 

word (ADMISSION DATE), then click OK.  

• In Based On, change the setting to Calendar Date. It will request that a column be 

selected. Any column may be selected because they all pull from the same area 

(e.g., Below Target). 

• Under Include, select the Current Entries checkbox. 

• Don’t add or change any settings under Show Values. 

• In Other, select the Word checkbox. 

5. Select the Element Settings. 

• How much time will the graph cover (3 months, 6 months, 12 months)? For this 

example we will set the graph to look back 1 month. 

• Set the Values Calculation. We want to “Count Clients” (i.e., how many clients were 

admitted). 

6. Select the Properties tab. 

• Enter a Title (e.g., Monthly Admissions). 

• Make the Legend visible and position it as desired (Bottom). 

• Add 3D effects as desired. 

• Set the Gauge Properties:  
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o Minimum = 0 (0 admission per month) 

o Maximum = 50 (50 admission per month) 

o Increments = 2 (count from 0 – 50 in increments of 2). Depending how high 

your maximum is, setting this to 1, or even 2 can be too much). 

o Band Width – This is the width of the gauge graph. A low value looks like a 

narrow band, whereas 100% fills the gauge in completely. This is a cosmetic 

setting and does not affect the data.  

o Total Angle – This is typically set to 180 degrees, but you may select any 

angle you wish. 

o Show as percent – Changes the increments to percentages. Do not select 

this property for this example. 

7. Select the Look tab. 

• Select the Primary checkbox (to allow date selection). 

8. Click Close. 

9. Position the field and stretch to meet margins. The graph will auto-size to fit the size of 

the field (the larger the field, the larger the graph). 

10. Click the Save icon to save and name your report (e.g., Graph – Monthly Admissions 

Gauge). Select Sites and user Groups as appropriate. 

Run Graph Reports 
1. Click the green Graph icon. Or, follow the path American Data - ECS > View > Report > 

Graph. 

2. When the client list appears, consider filtering for the appropriate clients. Since many 

graphs display data gathered for the facility, not for individual clients over time, it 

becomes critical to filter for clients that may already have an Inactive or Closed Account 

status in order to gather all of the resident data you need. 

3. Select the client(s) and click OK. 

4. Highlight the graph name, and click OK. 

a. If you don’t select a date, the graph will end today and look back from today. If 

you want to specify a date range, note that it’s only necessary to select an End 

Date. No start date is needed; the report will work back for the needed period 

based on the end date alone.  For example, if it’s a monthly report, you may 

want to select an End Date that is the last date of the previous month. 

5. The results appear on the screen. 

6. A unique feature of graph reports is that if you would like to see the chart entries 

associated with any of the data elements on the graph, you can hover your mouse over 

the data element (this changes your icon from a magnifying glass to a hand) and then 

click the element. A review screen appears with the relevant entries. 

 
 


